Sääasemaohjelmat > Cumulus

Internet päivitys v 1.8.5 (beta)

(1/3) > >>

Pentti Karvinen:
Internetissä ei aikaisemmalla versiolla näkyneet mittarit, mutta en siitä ollut huolissani sillä toisessa threadissa moinen "ominaisuus" kerrottiin. Nyt on anturit ulkosalla ja resetoin niin sääaseman, kuin ohjelmankin (päivitin uusasennuksena, version 1.8.5 (beta)). Mittaristo on silti vajaa.

Mittaristo sivulle suoraan.

Onko tietoa mihin näiden näkyminen perustuu? Eli onko kerättävä x aikaa/määrä dataa, vai onko jokin muu pielessä?

teutari:
Kyllä tiedot mielestäni pitäisi näkyä mittaristossa mutta ilmeisesti tämä uusi 1.8.5 beta päivitys ei ole päivittänyt kaikkia tiedostoja oikein?
Sammuta Cumulus ja kokeileppa  päivittää se 1.8.5 beta versio uudelleen jos se auttaisi.

J.Jäntti:

--- Lainaus käyttäjältä: Pentti Karvinen - Lauantai, 31.01.2009, 18:02 ---Internetissä ei aikaisemmalla versiolla näkyneet mittarit, mutta en siitä ollut huolissani sillä toisessa threadissa moinen "ominaisuus" kerrottiin. Nyt on anturit ulkosalla ja resetoin niin sääaseman, kuin ohjelmankin (päivitin uusasennuksena, version 1.8.5 (beta)). Mittaristo on silti vajaa.

Mittaristo sivulle suoraan.

Onko tietoa mihin näiden näkyminen perustuu? Eli onko kerättävä x aikaa/määrä dataa, vai onko jokin muu pielessä?

--- Lainaus päättyy ---

Firefoxini Error Logi rähisi boxover.js- ja dashboard.js-tiedostojen käsittelyvirheistä. Ne ovat kuitenkin oikeassa paikassa ja kunnossa, joten vika lienee reaaliaikaisen tiedon puuttumisessa. Nuo eivät ole millään tavalla riippuvaisia siitä, kuinka pitkään dataa kerätään.

Mittalukemat tulevat sivukoodin Javascript-osioon, jonka tiedot Gauges-sivuun upotettu Adobe Flash-osa lukee ja näyttää.
Jotta tuo toimisi, pitää ilmeisestikin Cumuluksen Realtime-järjestelmä olla päällä, jotta Javascript-osuus saa tiedot näytettyä (ja sitä kautta sivun Flash-osaan kaikki nuo mittatiedot näytille).

Kannattaa tarkistaa, että Cumuluksen Internet-asetukset ovat kohdillaan. Tee näin:

1. Avaa Cumulus ja mene Configuration --> Internet
2. Katso Web Settings-osiota. Asetusten pitäisi olla seuraavasti:

[X] Auto Update
[X] Use FTP rename
[ ] Delete before upload
Interval [ 5 ] minutes

[X] Enable Realtime
Realtime interval [ 30 ]

Ilmoita, kun olet tuon tehnyt, niin tarkistellaan tilannetta lisää.
Jos se ei tuosta tokene, pitää alkaa katsomaan, onko kaikki tiedostot varmasti paikallaan palvelimella.

Pentti Karvinen:
Muutin asetukset ylläolevan mukaisesti. Alla, kuinka olivat ennen muutosta.

[X] Auto Update
[ ] Use FTP rename
[X] Delete before upload
Interval [ 15 ] minutes

[ ] Enable Realtime
Realtime interval [ 3 ]

Aikaisemmin iltapäivällä, kun asensin uuden version Cumuluksesta poistin käsin vanhan hakemistorakenteen niin paikallisesta koneesta, kuin internetistäkin pois. Cumuluksen asennuksen jälkeen siirsin uudelleen tarvittavat tiedostot nettiin uudesta asennuksesta.

Heti ei ainakaan tullut muutosta näkymiseen, joten nyt sitten odotellaan tovi ja katsotaan mitä tapahtuu.

EDIT: Rename toiminnon ollessa päällä, sivut eivät päivity netissä. Muutin Delete kohdan käyttöön ja nyt päivitykset onnistuvat. (Ei vaikutusta mittaristoon.)

weatherc:
Laita vielä rasti tuohon "Enable realtime" ja käynnistä Cumulus uudelleen koska muistaakseni kaikki muutokset ei muuten tule voimaan. Ainakin kun itse sitä kokeilin niin kaikki mittarit eivät toimi ilman realtime:a.

PS. Myös FinWx & NWN käyttää reltimea kun haluat liittyä  ;)

Navigaatio

[0] Viestien etusivu

[#] Seuraava sivu

Siirry pois tekstitilasta